Back to overview
Resolved

Roblox Systems Removal

May 11, 2026 at 6:26pm UTC  –  May 11, 2026 at 7:07pm UTC
Affected services
Website
API

Resolved
May 11, 2026 at 7:07pm UTC

Maintenance ended

Updated
May 11, 2026 at 7:07pm UTC

Roblox services have now been removed.

Created
May 11, 2026 at 6:26pm UTC

We are removing our old Poly Defense roblox system to clean up our server.